Jump to content

Recommended Posts

Hello,

 

i tried to solve the Optistruct OS-T 1600 Tutorial, but after starting the two solvers (optistruct, acusolve) there is a convergence error of acusolve that stops the job:

 

Messages for the job:

 
 *** ERROR # 5202 ***
 Acusolve stops before FSI iteration achieves convergence.
 
 *** PROGRAM STOPPED: FATAL ERROR(s) ENCOUNTERED.

 

 

Does anyone knows the problem? I checked all steps of the tutorial and start it again, but the error still appears.

 

The next step was to change the exchange parameter of acusolve (min/max_stagger_iterations) and optistruct (min/maxEX) to 30. A Simulation of the Tutorial with only 0.02s worked.
To simulate the tutorial 0.1s or the whole 1s - as it is described in the Tutorial- still doesn´t work with a value of 100 for max_stagger and MAXEX. Another error appeared:

 

Fehlermeldung.thumb.jpg.7e81daad9af8a8adf71508d5786ae5cc.jpg

 

Does anyone has got experience with the tutorial OS-T 1600 and solved it successfull?

Thank you very much in advance.

Share this post


Link to post
Share on other sites

Hi @Prakash Pagadala

 

everything alright. I changed a few parameter in Optistruct and it seems to work.
I missunderstand an instruction in the tutorial.

 

Thank you nonetheless.

Share this post


Link to post
Share on other sites

@Prakash Pagadala
 

Hello Prakash,

 

I tried to built up an own FSI Problem and i got the same error as written April, 23.
What does this error generally means? What´s the problem?

 

*** ERROR # 3423 ***
 MUMPS solver encountered error with code -6.
 please contact support and provide .out and .stat files.
 

 *** INTERNAL PROGRAMMING ERROR ***
   in file "nltranend.F", at location # 364.
 
 ****  ABORTING RUN DUE TO AN INTERNAL ERROR  ****

 

Thank you in advanve.

 

FEM_001.out

FEM_001.stat

 

Share this post


Link to post
Share on other sites

Hi

I want to do tutorial OS-T 1600 FSI but in creating contact surface, when I click on "0 elements > elements" I cannot pick all the faces of the beam. When I select all the faces nothing happens and if I click on add, the message "No new elements have been selected" appears. Could you please let me know how to select all the faces? Do I need to have "all shell faces" or "all solid faces"?

In fact I managed the problem. It needs to have "all solid faces" to select elements.

Share this post


Link to post
Share on other sites

I think this is the problem...

 

*** WARNING # 9113
 It appears that the directory used for scratch files:
    /home/ac7754/fsi_slab_1/
 is located on remote filesystem. 
 This could result in very slow solver performance.
   Number of CPU processors        :         32

 

If possible share the model file to debug...

Share this post


Link to post
Share on other sites
8 hours ago, Question said:

Hi Prakash

Do you have a copy of FSI_AS_MANIFOLD.inp and FSI_OS_MANIFOLD.fem, please?

Thank you.

Can you give me the reference to the document about the files?

Share this post


Link to post
Share on other sites

Hi Prakash

Is it possible to look at attached file and let me know how to manage the problem, please?

It is OS-T: 1610 Thermal Fluid-Structure Interaction Analysis on a Manifold.

Thank you.

 

 ****  ABORTING RUN DUE TO UNEXPECTED ERROR CONDITION  ****
  
Error output from the solver:
==============================

External Code via CCI: *** ASSERTION in Function <cciNew> File <linux64/src/cci.c> Line <152>
External Code via CCI: *** Did not receive connection request from client after waiting for 2400 sec

 

hwsolver.mesg output from the solver:
==============================
 ****  ABORTING RUN DUE TO UNEXPECTED ERROR CONDITION  ****
 

optistruct:: Solver run finished after 40 minutes.

FSI_OS_MANIFOLD.fem

Share this post


Link to post
Share on other sites

Hi Prakash

When I run both tutorials OS-T 1600 and 1610, there is the following error.

acuSolve: *** ASSERTION in Function <ecdSetFatalError> File <ecd.c> Line <4208>
acuSolve: *** unable to match with external surface at 7 quadrature points
acuRun: *** ERROR: error occurred executing acuSolve
 

Could you please let me know how to manage it?

Thank you.

Share this post


Link to post
Share on other sites

Hi Prakash

I want to run an implicit simulation on a model with around 6 million elements. I set up the simulation as plate model in implicit analysis. However there are the following errors in my run. How can I solve that problem, please?

 *** ERROR # 4002 ***
 Running RADIOSS engine, 1 ERROR and 0 WARNINGs have been detected.
 
 ANALYSIS COMPLETED.
  
 *** SOME ERRORS WERE REPORTED DURING THE RUN,
 *** PLEASE VERIFY RESULTS AS THEY MAY BE INVALID.
 ************************************************************************
  A fatal error has occurred during computations:
  
  *** ERROR # 4002 ***
  Running RADIOSS engine, 1 ERROR and 0 WARNINGs have been detected.
  
  ANALYSIS COMPLETED.
  
  *** SOME ERRORS WERE REPORTED DURING THE RUN,
  *** PLEASE VERIFY RESULTS AS THEY MAY BE INVALID.
 
 *** PROGRAM STOPPED: FATAL ERROR(s) ENCOUNTERED.
 ************************************************************************
Errors reported during program execution

hwsolver.mesg output from the solver:
==============================
 
 *** ERROR # 4002 ***
 Running RADIOSS engine, 1 ERROR and 0 WARNINGs have been detected.
 
 ANALYSIS COMPLETED.
  
 *** SOME ERRORS WERE REPORTED DURING THE RUN,
 *** PLEASE VERIFY RESULTS AS THEY MAY BE INVALID.
 
 *** PROGRAM STOPPED: FATAL ERROR(s) ENCOUNTERED.

 

Solver FAILED

optistruct:: Solver run finished after 2 hours (10117 seconds).


Thank you.

Share this post


Link to post
Share on other sites

Hi

It is a NLGEOM implicit static analysis as you did for a plate. I set up my model as the plate one. The plate model is in attachment.

Is NLSTAT with LGDISP different than NLGEOM one, please?

Thank you.

plate_imp.fem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×