Jump to content

Recommended Posts

Dear sir/mam,

I created one script which can selects one  node and renumber it.But now what problem i am facing is when i am running my script first time it is working fine and i can select node by using left mouse click.But, if i am using same script second time (Note: I am creating new session) it is not picking node by mouse click but it is picking one node always automatically if i left click on screen anywhere but not picking correct node (Note: If i select node by id option it is able to pick entered node id with that automatically picked node).If i close Hypermesh and opens again it is working fine for first time but, again from second time i am facing same issue.

Please help me as soon as possible. Thanks in advance.

Thanks and regards.

Vikas Kumar

 

Share this post


Link to post
Share on other sites
5 hours ago, Q.Nguyen-Dai said:

Some screenshots or HM model to better understand your problem?

You can run this tool first time it will work fine second time just create new session and again run same .tcl script you will come to know the problem (Second time you will find not able to select node by left mouse click actually it won't work for any operation).

Note: before running the tool import any model in nastran profile i am using HM version 13.0.

Please help me as soon as possible. 

selectOneNodeSent.tcl

Share this post


Link to post
Share on other sites
On 1/8/2018 at 2:27 PM, Vikas Kumar said:

You can run this tool first time it will work fine second time just create new session and again run same .tcl script you will come to know the problem (Second time you will find not able to select node by left mouse click actually it won't work for any operation).

Note: before running the tool import any model in nastran profile i am using HM version 13.0.

Please help me as soon as possible. 

selectOneNodeSent.tcl

 

More than 200 lines of Tcl code for just selecting some nodes???

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×