Jump to content

Alex.01

Members
  • Content count

    10
  • Joined

  • Last visited

About Alex.01

  • Rank
    Beginner

Profile Information

  • Country
    Spain
  • Are you University user?
    No

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I am interested in this question too...
  2. Alex.01

    Distributed load on edge

    PERFECT! Understood! I really thank you!
  3. Alex.01

    Distributed load on edge

    Hi Sanjay, Thank you for your response. Could you give me an example with a picture please? I am not sure if I've understood your explanation.
  4. Alex.01

    Distributed load on edge

    Hi all, Does anyone know how to apply a uniformly distributed load along the edge of several elements? For example, I want to apply a load of 50 N/m along this nodes (see image) Thanks in advance, Alex
  5. Alex.01

    Element size?

    Awesome! Really thank you.
  6. Alex.01

    Element size?

    Hi all, Does anyone know if there is a tool in Hypermesh which says the average element size of a 2D mesh? I could use the measure tool and get the distance between two nodes of an element, but I am interested in get the average of all elements. Thanks in advance, Alex
  7. Sorry, I forgot to say that I am using Abaqus as solver, instead of Optistruct.
  8. Hi, I have a little problem with exporting local coordinate systems. I need them to postprocess welds but I don't use them in the analysis, so I must assign at least one node to the system that I have created. I do it by using this menu: Once I have assigned the nodes to the system (with "set displacemente" button), I export the model and I get a piece of code from the exported file like this: *TRANSFORM, TYPE=R, NSET=HM_auto_transform_14AA0 -4.463E-08, -0.9995139, 0.03117584, -1.0 , 1.4901E-08, -9.537E-07 **HMORIENT ORIGIN 3.2 ,-1.324 ,-0.18998 I was wondering if there is a way to export a local coordinate system with a NSET previously created in HyperMesh by using TCL. I know you can do this changing the button in HyperMesh (like I show in the image below), but when I try to do this with tcl commands, HM ignores it. Furthermore, in the command file this action is not recorded. I was trying with this: set name [hm_getstring "Name=" "Please specify a name for the NSET."] *createlistbypathpanel nodes 1 "Select nodes to create a weld" set lista [hm_getlist nodes 1] *clearlist nodes 1 *createentity sets name=$name ids={nodes $lista} *createmark systems 1 "by collector id" [hm_info currentcollector systcol] set sistema [hm_getmark systems 1] *createmark sets 1 $name *systemsetanalysis sets 1 $sistema Can someone help me?
  9. Alex.01

    Script: name for bolts

    Hi tinh, thanks for your answer but finally I could do the script. Anyway, what I had was this (bolt made with several 1d elements): And what I wanted was this (a tag with a ID for the bolt, i.e.5003) : But as I said before I could develop de script. You can delete this topic if you want considering it doesn't contribute to the forum. Many thanks.
  10. Hi all, I want to do an script which makes this: I have a model with a lot of bolts which are formed for 4 or 5 bar2 elements. I want to do an script which groupes each bolt (with its bar2 elements) and generates a tag or name for it (i.e. Bolt 1, Bolt 1001). The input would be 1 bar2 element, and I think I could do it by using *findmark command but I don't know how to carry on. Do you have any ideas to help me ? Thanks in advance. Regards, Alex
×