Jump to content
  • Announcements

    • Rahul Ponginan

      Please click here for a short but important announcement   03/26/17

      Dear Users Our Commercial and Academic users around the world can use these same forums here as before i.e. the Altair Support Forum , Commercial users from India with solver queries can go to the Solver Forum for India Commercial Users , Academic Users from India and AOC India Participants are requested to go to the Forum for India Academic Users and AOC India Participants , We will be tending to all queries in all the forums promptly as before, thank you for your understanding. 

Chennakesava Kadapa

Members
  • Content count

    3
  • Joined

  • Last visited

About Chennakesava Kadapa

  • Rank
    Newbie

Profile Information

  • Country
    United Kingdom
  • Are you University user?
    Yes
  1. missing white spaces in grid data in exporting mesh

    Thank you all for your answers. I did not like Tinh's solution because I do not like the idea of running a solver simply for the sake of obtaining a better format for the mesh data. It is cumbersome. @Nguyen, I could not figure out what "fixed format" and "long fixed format" are. I don't see them in v14.0. I solved my problem by 1.) developing a simple awk script for the file generated using v14.0, 2.) installing 2017 version in which Optistruct has 'free format' which exports the data in comma separated format which I can process easily. Thank you.
  2. missing white spaces in grid data in exporting mesh

    Thank you Nguyen and George, for your answers. Unfortunately, they do not help my cause. I am using Hypermesh only to generate meshes for my in-house FEA code. So, the RADIOSS reader does not help me. I have to have the coordinate with some delimiter which I can process to be readable into my code. Textpad is my default text editor. I also opened the .rad files in Notepad, Wordpad and MS Word, and I didn't see any difference in the format. I have attached the file for your reference. Please not me know if I am doing something wrong. The only option I can think of now is to generate to an AWK script to break the coordinates. I must say that this is very inconvenient. Please let me know if there is any other way around this. leafvalve3dleaf_0000.rad
  3. Hello everyone, I am having trouble exporting the mesh from Hypermesh. Some white spaces separating the fields are missing. *) With the RADIOSS profile, the first three nodes of the grid data look like this. 1 10.4352852680878 0.374999999999996 1.69690861652916 2 10.0920996147679-3.8857805861880E-15 1.59540682856021 3 10.2957517115474-3.5527136788005E-15 1.49409343503715 *) The situation is even worse with OptiStruct. The output file (first three nodes) looks like this. GRID 1 10.435290.375 1.696909 GRID 2 10.0921 0.0 1.595407 GRID 3 10.295750.0 1.494093 I don't want to create white space manually because the meshes I work with, in general, contain thousands of nodes. So, I need a proper solution for this issue. I am using the HyperWorks14.0 - student version. Thanks, Chenna.
×