Jump to content
  • Announcements

    • Rahul Ponginan

      Please click here for a short but important announcement   03/26/17

      Dear Users Our Commercial and Academic users around the world can use these same forums here as before i.e. the Altair Support Forum , Commercial users from India with solver queries can go to the Solver Forum for India Commercial Users , Academic Users from India and AOC India Participants are requested to go to the Forum for India Academic Users and AOC India Participants , We will be tending to all queries in all the forums promptly as before, thank you for your understanding. 
    • Rahul Ponginan

      Introduction to Explicit Analysis using RADIOSS.   11/02/17

      We are excited to announce the release of updated RADIOSS ebook, Introduction to Explicit Analysis using RADIOSS. We have added new tutorials, more FAQ's....etc with more topics covered. This study guide aims to provide a good introduction into the exciting and challenging world of explicit Finite Element Analysis.
      You can download the updated RADIOSS ebook here: Introduction to Explicit Analysis using RADIOSS                                                           
pratik gadve

Leaf Spring Nonlinear Analysis using Radioss solver

Recommended Posts

Dear Sir,

 

I am currently working on leaf spring non-linear analysis on Radioss solver. I am finding some errors after giving run on Radioss. Please help me in correcting this error and let me know where I am committing mistake. I have attached RAD starter file, engine file and output file below.

 

Regards,

Pratik Gadve

 

 

 

Share this post


Link to post
Share on other sites

Hi Pratik,

Please recreate the Type 7 interface in the model. And also check the rigids in the model. The master node in RBE3 is a slave node of another RBE2 created, which is not possible. Please correct the same.

Share this post


Link to post
Share on other sites
On 1/31/2018 at 6:01 PM, George P Johnson said:

Hi Pratik,

Please recreate the Type 7 interface in the model. And also check the rigids in the model. The master node in RBE3 is a slave node of another RBE2 created, which is not possible. Please correct the same.

Hi George,

 

Thank you for suggestion! I have corrected rigid elements and also recreated Type 7 interface. Still I am getting error of initial penetration. I have done penetration check of elements too. It has passed penetration check. Will you please check my model and do some corrections in interfaces if required ? Also during Type 7 while selecting Master surface external it is not getting selected. Check if there is bug while selecting that in 17 version. So i kept Master Surf All in Type 7. Please check whether engine parameters inputs are correct too.

I am struggling to solve this problem from many days.

 

I have attached my corrected file with error out file.

 

 

Thanks in advance for Altair support team.

 

Regards,

Pratik Gadve

 

 

 

Share this post


Link to post
Share on other sites
On 2/3/2018 at 3:08 PM, George P Johnson said:

Hi,

You can try with the files attached.

 

trail_7_0000.rad

trail_7_0001.rad

Hi George,

 

Many many thanks. I have got the results but I am unable to do post processing as output I am getting is .rst file 

 

trail_7_0000_0001

and

trail_7_0001_0001

 

I have Hyperview which requires H3D file.

Will you suggest how to open .rst file and also how to get output file in H3D format using HYPERMESH V17 and Radioss solver ? Let me know internal settings/control cards settings to be done to get that.

 

For above run I directly loaded engine file you gave. Since I am beginner, will you let me know what are manual engine file assistant inputs (values) you gave in previous attached .rad file ? please send snapshot of it if possible.

 

Thanks in advance.

 

Regards,

Pratik

 

 

 

 

 

Share this post


Link to post
Share on other sites

Hi,

You can do post processing with the animation files (A001,A002....) or the final .h3d only. I have tried with the same (trail_7_0000.rad and trail_7_0001.rad) files which shared above and h3d was generated. Ensure the engine file (_0001.rad) is also available in the same working directory and try running again.

The basic control cards required for RADIOSS solver (run time, animation files, time history, results...) is as below:

 

 

engine.PNG

Share this post


Link to post
Share on other sites
On 2/5/2018 at 3:24 PM, George P Johnson said:

Hi,

You can do post processing with the animation files (A001,A002....) or the final .h3d only. I have tried with the same (trail_7_0000.rad and trail_7_0001.rad) files which shared above and h3d was generated. Ensure the engine file (_0001.rad) is also available in the same working directory and try running again.

The basic control cards required for RADIOSS solver (run time, animation files, time history, results...) is as below:

 

 

engine.PNG

HI George,

 

Thanks for help. Now I got H3D file. But still there is some problem. I am getting zero displacement , zero Von mises stress in Hyperview results. I have attached outout file H3D file below. Please let me know if there is any input is missing. Boundary conditions and forces seem to be OK and values of force applied are taken from experimental result.

 

Waiting for your reply George. Thanks.

 

Regards,

Pratik

 

 

 

 

Share this post


Link to post
Share on other sites

Hi,

This s because of the loading you have applied. The load is applied is applied to the master node which will be equally distributed to all the slave nodes. In your case the loading effect is nullified. I just applied the load to the lower rigid body (master node of the rigid body in the third leaf) and the model is giving results.

Ensure the load is applied correctly at the required location so that results are created.

leaf.gif

 

The model file is also attached for your reference.

leaf_model.hm

Share this post


Link to post
Share on other sites
On 2/5/2018 at 9:43 PM, George P Johnson said:

Hi,

This s because of the loading you have applied. The load is applied is applied to the master node which will be equally distributed to all the slave nodes. In your case the loading effect is nullified. I just applied the load to the lower rigid body (master node of the rigid body in the third leaf) and the model is giving results.

Ensure the load is applied correctly at the required location so that results are created.

leaf.gif

 

The model file is also attached for your reference.

leaf_model.hm

Hi George ,

 

 

Thank you for help. I have reapplied force. Now I have got the results. Just a small doubt. I do not have value of EPS @ UTS. Is it necessary nonlinear parameter to be given while giving run on Radioss ? I have attached steel properties below. Please let me know, is there any alternate parameter we can give as input in Radioss(from given excel chart only ) instead of EPS @ UTS ? I want to avoid giving stress-strain plot as well. 

 

 

Regards,

Pratik

 

Share this post


Link to post
Share on other sites
3 minutes ago, George P Johnson said:

Hi Pratik,

It is not necessary to provide engineering strain at UTS for /MAT/LAW2. You can run with Yield stress and UTS values.

Ok George. Thank you.  I want to try another way also. Will you give me idea of how to give input stress strain curve for steel material along with its Young's modulus,rho and poisson ratio ?

 

Regards,

Pratik

Share this post


Link to post
Share on other sites

Hi Pratik,

If you want to input stress strain curve for an elasto plastic material then use /MAT/LAW36 , where you can input E, Rho and stress-strain curve.

Please note that the stress strain curve should start from the yield point of your curve, that is post yield values should be provided. I recommend you to go through the Help Menu on /MAT/LAW/36 where you will get more information on the same.

Share this post


Link to post
Share on other sites
7 minutes ago, George P Johnson said:

Hi Pratik,

If you want to input stress strain curve for an elasto plastic material then use /MAT/LAW36 , where you can input E, Rho and stress-strain curve.

Please note that the stress strain curve should start from the yield point of your curve, that is post yield values should be provided. I recommend you to go through the Help Menu on /MAT/LAW/36 where you will get more information on the same.

Ok George. Thank you for clearing all my doubts. Will consult you whenever I get stuck up in nonlinear analysis in Radioss.

 

Regards,

Pratik

Share this post


Link to post
Share on other sites
On 2/6/2018 at 2:07 PM, George P Johnson said:

Hi Pratik,

If you want to input stress strain curve for an elasto plastic material then use /MAT/LAW36 , where you can input E, Rho and stress-strain curve.

Please note that the stress strain curve should start from the yield point of your curve, that is post yield values should be provided. I recommend you to go through the Help Menu on /MAT/LAW/36 where you will get more information on the same.

Hi George,

 

I need a help again. Whatever above result I got in leaf spring analysis using Radioss solver, it is not proper. Please check animation file. I have given material inputs properly still the leaf sliding motion is not correct. Moreover the master node of RBE2 of right eye of first leaf must move along with slave nodes, isn't it? Please check with animation files. Whatever load and material values given are proper. Please do some necessary correction and let me know where I am going wrong. Acceptable range value of disp is 190 to 220mm and von mises is around 1200 MPa.

 

Thanks and regards,

Pratik

trail_16_Disp.avi

trail16_von_mises.avi

Trail16 yts 1200 uts 1600.hm

trail16.h3d

Share this post


Link to post
Share on other sites
On 2/9/2018 at 8:40 AM, George P Johnson said:

Hi Pratik,

Please try with the file attached.

 

model.hm

 

 

 

leaf_spring.gif

 

Hello George,

 

I am getting results but results and animation behavior are not satisfactory. They are not matching with experimental and Ansys results and animation behavior. Please look at attached ANSYS animation file and image for constraints.

 

As per your suggestion I have given run on Radioss and post processing H3D file in Hyper view. You can see in H3D file attached that for fraction of second at the end of animation,  leaf is getting back (Spring back like effect you can check out in slow motion). Helper must touch 2nd leaf and assist it to move upwards.

 

Final value should match Ansys results that I have attached. All the material, property, Load value and rigid body constraints dofs are correct.

Currently Disp value has reached upto 154mm. Experimental & Ansys value is 211mm .

Currently von mises value is 1024 MPa. Exptal & Ansys value is 1152MPa.

 

Please help me out George. Let me know where I am going wrong.

 

Thanks & Regards,

Pratik

leaf spring Boundary conditions info.png

our result should match this ANSYS von mises value.avi

Our result should match this DISP max value.AVI

gradual_silde contact acc to Altair_Trail3.hm

Trail3.h3d

Share this post


Link to post
Share on other sites
5 minutes ago, George P Johnson said:

Hi Pratik,

Can you please share the Ansys model file,so that we can recheck with the model and can ensure the model setup is correct.

 

Hi George,

 

Unfortunately I do not have ANSYS model file. I have only animation file that I have already shared with you. At right eye end of first leaf Shackle is connected. Thats why only X translational and Z axis rotational allowed. Rest all setup is correct. I guess may be helper is not pushing 2nd leaf. There might be some error in TYPE 7. Please check why why helper is not pushing upwards.

 

Regards, 

Pratik

Share this post


Link to post
Share on other sites
10 minutes ago, George P Johnson said:

Hi Pratik,

Is the loading correct,  that is the force values?.

If you have the final animation file (not .avi video) please share the same.

HI George,

 

Yes loading is correct. I distributed 11134N force equally among all bottom nodes. Load value for each node is correct. 

I have already shared current H3D file (Trial 3.h3d file attached above)  I do not have ANSYS H3D file. I have only avi video just for reference.

 

Regards, 

Pratik

Edited by pratik gadve

Share this post


Link to post
Share on other sites
3 minutes ago, George P Johnson said:

Hi Pratik,

Define a Type 2 interface between 3rd leaf and center pad 2 and similarly between center pad 2 and 2nd leaf and try running the analysis.

Please check the attached gif.

 

 

leaf.gif

Hi George,

 

Could you share modified .hm file of the same ? 

 

Regards,

Pratik

Share this post


Link to post
Share on other sites
19 hours ago, George P Johnson said:

Hi Pratik,

Define a Type 2 interface between 3rd leaf and center pad 2 and similarly between center pad 2 and 2nd leaf and try running the analysis.

The model file is attached for your reference.

leaf_model.hm

 

Please check the attached gif.

 

leaf.gif

 

 

 

l.PNG

Hello George,

 

I have run the above leaf model you shared yesterday.

 

During analysis in Radioss solver I am getting output results as follows:

 

NC=  232300 T= 1.8043E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2319.28 s  REMAINING TIME=     511854.82 s
 NC=  232400 T= 1.8051E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2320.30 s  REMAINING TIME=     511857.71 s
 NC=  232500 T= 1.8058E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2321.35 s  REMAINING TIME=     511867.20 s
 NC=  232600 T= 1.8066E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2322.38 s  REMAINING TIME=     511873.60 s
 NC=  232700 T= 1.8074E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2323.39 s  REMAINING TIME=     511876.25 s
 NC=  232800 T= 1.8082E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2324.44 s  REMAINING TIME=     511885.95 s
 NC=  232900 T= 1.8089E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2325.47 s  REMAINING TIME=     511892.33 s
 NC=  233000 T= 1.8097E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2326.52 s  REMAINING TIME=     511901.79 s
 NC=  233100 T= 1.8105E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2327.58 s  REMAINING TIME=     511914.97 s
 NC=  233200 T= 1.8113E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2328.61 s  REMAINING TIME=     511921.11 s
 NC=  233300 T= 1.8120E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2329.66 s  REMAINING TIME=     511930.76 s
 NC=  233400 T= 1.8128E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2330.72 s  REMAINING TIME=     511943.91 s
 NC=  233500 T= 1.8136E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2331.75 s  REMAINING TIME=     511950.03 s
 NC=  233600 T= 1.8144E-02 DT= 7.7670E-08 ERR=  0.0% DM/M= 0.0000E+00
 ELAPSED TIME=       2332.78 s  REMAINING TIME=     511956.14 s

 

 

you see remaining time should get decrease.

 

But it is increasing !!

 

You have got results on same hm file you had shared above. I am not getting it. Please check if some error in giving starter or engine inputs.

leaf_model (1).hm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×