Jump to content
  • Announcements

    • Rahul Ponginan

      Please click here for a short but important announcement   03/26/17

      Dear Users Our Commercial and Academic users around the world can use these same forums here as before i.e. the Altair Support Forum , Commercial users from India with solver queries can go to the Solver Forum for India Commercial Users , Academic Users from India and AOC India Participants are requested to go to the Forum for India Academic Users and AOC India Participants , We will be tending to all queries in all the forums promptly as before, thank you for your understanding. 
no name

How To Import other file ie: IGES file to Feko

Recommended Posts

Hi,

I would like to have some guide on import other files into Feko. it is because when I import some files, there are some parts missing. kindly may I know how do need to import other files to FEKO without effecting the original model?

 

 

thank you for your kind help.

 

Share this post


Link to post
Share on other sites

Hi no name

 

First make sure you are using the latest version of FEKO, that is 2017.

Secondly, you can experiment with the import options on the Advanced tab. Specifically you can try there to switch on/off the option, "Use two step import process".

 

If you have access to the tool that the iges file was created in, perhaps there you could export the model to another format: Parasolid is first prize but also step should give good results in FEKO compared to other types.

 

If there are still issues, please attach the iges file here.

Share this post


Link to post
Share on other sites

Dear Mel,

Good day,

 

I have already tried, the result still shows the same. there some part missing ie: port, substrate did not define, ground missing, all part is set to by default. While I have already defined in other design software. Kindly help to explain me further how to import correctly, so There would be no part missing and not define when import into FEKO. Thank You for your kind help. Attach is when I have import IGES file to FEKO.

image.png.8a22ea1897c6fb75dc7f1867408fd650.png

Share this post


Link to post
Share on other sites
On 11/23/2017 at 10:53 PM, mel said:

Hi no name

 

First make sure you are using the latest version of FEKO, that is 2017.

Secondly, you can experiment with the import options on the Advanced tab. Specifically you can try there to switch on/off the option, "Use two step import process".

 

If you have access to the tool that the iges file was created in, perhaps there you could export the model to another format: Parasolid is first prize but also step should give good results in FEKO compared to other types.

 

If there are still issues, please attach the iges file here.

Dear Mel,
Good day,
 
I have already tried, the result still shows the same. there some part missing ie: port, substrate did not define, ground missing, all part is set to by default. While I have already defined in other design software. Kindly help to explain me further how to import correctly, so There would be no part missing and not define when import into FEKO. Thank You for your kind help. Attach is when I have import IGES file to FEKO.

array 2x2 antenna at 2.6Ghz.igs

Share this post


Link to post
Share on other sites

Material parameters, substrates and face settings (whether PEC or dielectric surface etc.) are parameters that will not be included / translated with CAD exports.

 

It does not look like much is missing. Follow these steps:

1) Union all the parts

2) Remove the finite thickness by deleting the redundant faces, such as those ones at the very top z of the model (I doubt that a 35 micron thick metal would look any different EM wise than an infinitely thin one, unless you are simulating at mm wave)

2) Define the substrate parameters: name, erps_r, etc

3) Apply the substrate to the "region" in the details tree.

4) Set the face properties: either PEC or dielectric surfaces. This is also shown in the GetStarted guide in the doc folder of FEKO (see the patch antenna there).

5) Add the port. The port edge should be either completely outside or completely inside the dielectric. See comments here.

6) Add the volagesource.

7) Set the frequency

8) Mesh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×